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Object Library

Collision CSI Fire Rail Marine

SmartRoads
User QuickGuide

 

SmartRoads now features a new interface that makes diagramming 
a breeze. New and existing users will fi nd that SmartRoads will improve 
effi ciency with features including the Properties dialog box,  Actions 
tab (eliminates right clicking objects), Scene tab and especially the 
Help tab (displays actions and options of a selected tool or object).

Create diagrams quickly and easily by dragging and dropping 
roadways and objects onto the scene. SmartRoads allows the user to 
create and control diagrams.

You’ll be amazed by the ease of use and the speed to create 
diagrams. Creating professional diagrams will take minutes, not  
hours or days.

1. Menu Bar
2. Tool Bar
3. Object Library

4. Actions, Scene & Help Dialog
5. Canvas
6. Properties Dialog
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To add objects, drag and drop them from the library (positioned on the 
left of the canvas). 
Choose from over 600 categorized objects (commercial vehicles, signs, 
lights, buildings, wildlife...) and from over 3500 exact vehicles (1971-
2006) using the “Choose Exact Vehicle” button positioned on the bottom 
of the Object Library.

The Object Library contains thousands of models divided into 5 
categories to make them easy to fi nd.
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Getting Started 
Populating the Scene

The fastest way to get started on a diagram is to open a template:
File > Open Template Library
SmartRoads includes over 60 templates to choose from, or the user can 
create their own saved templates. 

To save diagrams as templates:
File > Save As Template
The user has instant access to pre-drawn intersections and roadways 
- simply insert the objects that the diagram requires.
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Drawing a Diagram from Scratch

T-Intersection
A T-intersection is built as quickly as a 4-way intersection, the only 
difference is the positioning of the second road segment.

1. Drop “Horizontal Straight Road” onto canvas

2. Drop 2. Drop “Vertical Straight Road” over existing road

3. A T-Intersection has been created.

1. Drop “Horizontal Straight Road” onto canvas

2. Drop 2. Drop “Vertical Straight Road” over center 
line of “Horizontal Straight Road”     

Place an “Arc Road Segment”
on the scene.

Curved Road
SmartRoads 2 enables the creation of curved roads and curved 
intersections. The curved road component behaves the same way as a 
straight road component except it has additional grips to edit the radius 
of the road segment. 

Setting up SmartRoads
Before getting started, it is advisable to set up the SmartRoads 
properties (see below) so every component dropped onto the scene will 
have the properties needed. A great time saver!

These settings will be saved as default for the future.

1. Select the Scene Tab > SmartRoads Properties

2. Set up the SmartRoads preferences in the properties dialog

Set up: road color, road line color, lane width and road line properties

SmartRoads Components

The most powerful feature in SmartRoads is 
the SmartRoad Components. Simply drag the 
components onto the canvas and intersect 
roads to create intersections, add lanes, 
crosswalks, turning lanes, medians...

The fi nished intersection or roadway is 
placed as a fully editable object.

Actual drawing tools will not be required 
most of the time. The scene can be 
constructed using models from the object 
library. Simply drag & drop the required 
elements from the object library to the 
canvas - then adjust the properties as 
required.

Create a diagram in minutes ! 

4-way Intersection
Creating an intersection is as easy as dropping 2 SmartRoad components 
from the object library on top of each other.

A curved road can be created by placing a straight road fi rst then convert  
using the actions tab.

The actions tab allows the user to toggle whether the road is straight or 
curved.

Horizontal
Straight Road

Vertical
Straight Road

Horizontal
Straight Road

Vertical
Straight Road

Arc RoadArc Road
Segment
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Editing your Intersection/Roadway

Click on different parts of the intersection to locate the grips to modify it. 
Grips and the properties dialog can be used to modify an intersection to 
fi t your needs.

Editing your Intersection

Adding other Components 
to an Intersection/Roadway

To add access roads, driveways or crosswalks, simply drag symbols from 
the object library and drop on the roadway.

Sidewalks, grass/dirt/paved shoulders can also be added by selecting an 
outside lane or the center of an intersection and then using the actions tab 
to add the desired edge. 
When a lane is selected, the curb will be applied to the closest edge.
Selecting an intersection applies the object to all edges of the intersection.

Editing Road Lines
Change road lines from the selected defaults in the SmartRoads 
properties to any road line such as a solid, dashed, double solid, solid-
dashed line.... 
1. Select a road line

Use the yellow grip to change length and position of the selected road

Use the orange grip to edit the amount of lanes.

Road-grips change:
- lanes (+,-)
- road (angle, length)

Radius grips for right-turn lane change:
radius of right-turn lane from 
corner to right-turn lane

Road-grips change:
- angle, length
- radius
- lanes (+,-)

Grips for left-turn lanes change:
- length, position of right-turn lanes 
- lanes (+,-)

Click in the center of your intersection 
to get the following grips.

Move 
Rotate

Use the yellow grip in the center of a segment to 
change the radius of a segment.

Other grips behave like those of the straight road/
segment (see above)

Curved Road/Segment

Editing Roads/Legs and Lanes

Select a roadway or leg of an intersection and use grips to adjust the 
object to suit your needs.

Straight Road/Segment

Editing Lanes
 Normal lanes can be converted to suit the diagramming needs.
1. Select lane

To edit lane width, select lane and edit lane width in the properties 
dialog below the canvas.

2. Edit properties in the dialog window below

To add a crosswalk to an intersection, select 
“add crosswalks” in the actions tab.

Left Turn Lanes
A left turn lane can be edited by using grips or the properties dialog.

2. Select the type of lane to be converted in the actions tab. 

Use orange grips in the center of the left-turn lane to adjust lane
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Vehicle Damager
> Select Object
> Actions Tab choose:
 > Damage Model
or:
> Right-click car - select Damage Model

A dialog window allows the model to be damaged precisely according to 
Total Station or hand measurements.

To damage model :

Select area, position points 
or delete area

Right-click to add points

The Help Dialog provides a quick overview making the initial run in 
SmartRoads a breeze. It also provides additional information on how to 
use tool, objects and anything else selectable.

Simply select a tool or object to view the information that can be used to 
make the creation of a diagram fast and effi cient.

In-depth Help can be used with search and full descriptions of 
SmartRoads and its components.
Menu > Help > Contents or [ F1 ]

Scene
Edit Scene Properties in the scene tab which is divided into: 
Scene Properties
SmartRoads Properties
Choose and edit properties in the Properties box.

Actions

The actions tab is designed to show options available like converting 
lines, Open Vehicle Damager and many more. The actions differ 
depending on the object or tool selected.
It is designed to make SmartRoads more intuitive. 

No more hidden functions!  No need for right-clicking!

Action, Scene & Help

Help

Scene Properties
Edit the ground color and the Grid (size, turn on-off) in the scene 
properties.

SmartRoads Properties
See page 2.

Object - grips1:
move object
rotate

Object - grips2:
move object
rotate
resize

1  cars - resizable in properties
2 resizable objects

Adding Objects

The Object Library allows the user to choose symbols appropriate for:

Choose from sub-libraries within the categories to fi nd a symbol. 
When the correct symbol is located, simply drag it onto the scene to 
the desired location. Notice the grips that appear which allow editing 
of position, rotation or size. The symbols properties appear in the 
Properties Editor at the bottom of the screen. Properties edits revise 
in real time. Cut, copy, paste are found on the right click menu after 
selecting the symbol. 

Collision CSI Fire Rail Marine

SmartRoads includes over 3500 exact vehicles (1971-2006). To insert a 
vehicle, use the “Choose Exact Vehicle” button positioned on the bottom 
of the Object Library.
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Copy

Drawing Tools

Color Tools

Select
Snap

Layers

Editing Drawing Shapes
Once a drawing tool is selected, choose line type (dotted, dashed...). It is 
also possible to change the line in the actions window, for example, from 
a line to skidmark.

Select an object and click one of the buttons to edit the color.

Use the select tool to edit any object. The Property dialog will appear at 
the bottom of the canvas. Change all properties in that form. Standard 
Windows functions are available on the right click menu for all objects. 

Cut [ Ctrl+X ] Delete [ Del ]

Copy [ Ctrl+C ] Undo [ Ctrl+Z ]

Paste [ Ctrl+V ]

Click to turn features on & off  for precise, fast and easy diagramming.

Measurement

Controls the visibility of lines, points, numbers, objects ...
Use the properties box to assign layers in the properties box, 
adding up to 250 layers.

Print
Click print to send the diagram to the print preview form where the 
program automatically scales the diagram for the printer’s paper size. 
Once the diagram is in Print Preview, the scale can be adjusted using the 
drop down or by typing in a new scale and clicking on “Update Scale”. 
Using the menu, choose landscape or portrait to better fi t the format of 
the diagram. Use the Vista fx title blocks by clicking on fx title blocks by clicking on fx “Edit Title Block”
and use the drop down and entry fi elds. Once printed, those settings 
become the default and will be saved with the diagram fi le. 

Print Selected Area 
Allows choice of a certain scale and/or a specifi c area needed to print at 
the same time. Use the drop down list beside the printer icon on the tool 
bar and click on Print Selected Area, or File > Print Selection under the 
File menu. A blue rectangle appears on the diagram, representing paper 
size at the scale shown in the form. The scale can be changed with the 
blue rectangle changing in real time to display the desired print area. 
The blue rectangle can be moved to print only the area required.  

Print

Measure distances and angles or place a scale bar.

Tool Bar
[ Esc ]

Zoom
Show all objects, shows all objects on scene

Zoom,  in: (left click), out: (right click) 
    Zoom to Area ( draw a box )

Percentage

[ File > Print ]
[ File > Print Selected Area ]

Snap  [ F5 ]   

Ortholock (horizontal, vertical) 

Aspect Lock  (Squares, Circles)

Snap to Grid

Stroke

Fill

Text

Objects 

These functions are also available by right-clicking an object.

Point  left - click : add point

Line  click: start, click for end point

Rectangle click: start, drag, click: fi nish

Ellipse  click: start, drag, click: fi nish

Polygon  click: start, click add segment, right-click: fi nish

Arc  click: start, click: end, resize grip to fi t

Text  click where text is to appear

Image Tool places images

Click and drag over the area to be measured and click to fi nish.
Adjust properties for display options.

Click to drop on scene. Use grips. 
Measures relative angles between objects or lines. 

Click to drop on scene. Use horizontal grips to stretch. Auto resizes to 
nearest 10 unit. Use vertical grips to thicken and enlarge display.

Select measurement tool to get the following options in the 
properties dialog.




